Troubleshoot CLEAR Engine errors

2022/10/13 |

Symptoms

The CLEAR Engine service fails to start.

Cause

Various reasons can cause CLEAR Engine fail to start. This article describes common causes and solutions to CLEAR Engine start errors.

Resolution

  • In Windows Logs > Application, there is an error from SkyAnalyzer Engine:

      Service cannot be started. InvalidStorageException: CLEAR Engine license could not be verified because system time is not within the expected range.
    

    You receive this error because the license store is corrupted. While a likely cause is that the system time has been changed, other reasons, such as changes in hardware or network configurations, renaming the computer, or joining the computer to a domain, might corrupt the license store as well.

    To reinitialize the license store, follow these steps:

    1. Open Windows PowerShell as administrator, and enter the following commands:

       Remove-Item "C:\ProgramData\Lucent Sky\CLEAR"
       ."C:\ProgramData\Lucent Sky\CLEAR Engine\Maintenance\Current\SkyAnalyzer.Engine.Installer.exe" -I
       Start-Service "CLEAR Engine"
      
    2. A dialog box will appear to confirm that the license store has been initialized.
    3. Use either the Web UI or the installer to activate the product key.
  • In Windows Logs > Application, there is an error from SkyAnalyzer Engine:

      Service cannot be started. System.Exception: Storage is offline. It is likely caused by another node in the cluster is currently in maintenance.
    

    You receive this error because the storage is offline. The storage is taken offline when CLEAR Engine is performing maintenance. If the CLEAR Engine instance belongs to a cluster, it is likely that another node in the cluster is being updated.

    If the CLEAR Engine is a standalone instance or you are certain that the storage can be brought online safely, follow these steps to bring the storage online:

    1. Open Windows PowerShell as administrator, and enter the following commands:

       Remove-Item ((Select-Xml -Path "C:\Program Files\Lucent Sky\CLEAR Engine\SkyAnalyzer.config" -XPath "skyAnalyzer/add[@key='StorageRoot']").Node.value + "\storage_offline")
       Start-Service "CLEAR Engine"
      
  • In Windows Logs > Application, there is an error from SkyAnalyzer Engine:

      Service cannot be started. System.Data.DataException: An exception occurred while initializing the database.
    

    In addition, in Windows Logs > Application on the SQL Server, there is also an error from MSSQLSERVER or MSSQL$SQLEXPRESS:

      SQL Server is not ready to accept new client connections. Wait a few minutes before trying again. 
    

    You receive this error because CLEAR Engine started before the SQL Server is ready. This usually occurs when CLEAR Engine and SQL Server are installed on the same server, and the server restarted while under heavy load.

    Manually start the CLEAR Engine service when the SQL Server is ready. If this error occurs frequently, consider changing the startup type for CLEAR Engine from Automatic to Automatic (Delayed Start).