Troubleshoot CLEAR Engine errors

2025/6/16 |

Symptoms

The CLEAR Engine service fails to start.

Cause

Various reasons can cause CLEAR Engine fail to start. This article describes common causes and solutions to CLEAR Engine start errors.

Resolution

  • In Windows Logs > Application, there is an error from SkyAnalyzer Engine:

      Service cannot be started. System.Exception: CLEAR Engine could not start because the license store is invalid. Reinitialize the license store and reactivate the prodcut key.
    

    You receive this error because the license store is invalid. It is usually caused by significant changes in system configuration or system time.

    To reinitialize the license store, follow these steps:

    1. Open PowerShell as administrator, and enter the following commands:

       Remove-Item "C:\ProgramData\Lucent Sky\CLEAR"
       ."C:\ProgramData\Lucent Sky\CLEAR Engine\Maintenance\Current\SkyAnalyzer.Engine.Installer.exe" -I
       Start-Service "CLEAR Engine"
      
    2. A dialog box will appear to confirm that the license store has been initialized.
    3. Use either the Web UI or the installer to activate the product key.
  • In Windows Logs > Application, there is an error from SkyAnalyzer Engine:

      Service cannot be started. System.Exception: CLEAR Engine could not start because the storage is offline. Ensure the storage is online and no nodes in the cluster is performing maintenance.
    

    You receive this error because the storage is offline. The storage is taken offline when CLEAR Engine is performing maintenance. If the CLEAR Engine instance belongs to a cluster, it is likely that another node in the cluster is being updated.

    If the CLEAR Engine is a standalone instance or you are certain that the storage can be brought online safely, follow these steps to bring the storage online:

    1. Open PowerShell as administrator, and enter the following commands:

       Remove-Item ((Select-Xml -Path "C:\Program Files\Lucent Sky\CLEAR Engine\SkyAnalyzer.config" -XPath "skyAnalyzer/add[@key='StorageRoot']").Node.value + "\storage_offline")
       Start-Service "CLEAR Engine"
      
  • In Windows Logs > Application, there is an error from SkyAnalyzer Engine:

      Service cannot be started. System.Exception: CLEAR Engine could not start because startup validation failed. (ERROR_CODE)
    

    You receive this error because CLEAR Engine detected an error during startup validation.

    Contact Lucent Sky support to learn how to resolve the underlying issue.