Troubleshoot Lucent Sky AVM CLI errors

2025/08/08 |

Symptoms

When you access the CLI, you receive an error message with a negative error code. The CLI also exits with the error code.

Cause

Various reasons can cause the CLI to return an error. This article describes common causes and solutions to CLI errors.

For CLI errors that occurs after uploading the source code archive, view the following article in the Lucent Sky Knowledge Base:
Troubleshoot source code upload errors

Resolution

  • An error code between -10 and -99 indicates authentication or authorization errors. Verify the API key is valid, and that the user has permissions to perform the task.

  • An error code between -100 and -999 indicates that the error was returned by CLEAR Engine. Follow the error message to resolve the error.

  • The error code -20000 indicates that an unexpected error has occurred during the operation. If the error persists, contact Lucent Sky support.

  • The error code -20004 or -20006 indicates an network issue between the CLI and CLEAR Engine. Verify that the CLEAR Engine service is running, that the endpoints are properly configured, and that the CLI can connect to CLEAR Engine over TCP/5759.

  • The error code -20005 indicates that a timeout occurred during the operation. This commonly occurs when uploading a large source code archive over slow network connection.

For learn more about the error codes that the CLI might return and their resolutions, view the following article in the Lucent Sky Knowledge Base:
Lucent Sky AVM CLI Reference