Troubleshoot Lucent Sky AVM CLI errors

2021/12/21 |

Symptoms

When you access Lucent Sky AVM CLI, you receive an error message.

Cause

Various reasons can cause the CLI to return an error. This article describes common causes and solutions to CLI errors.

For CLI errors that occurs after uploading the source code archive, view the following article in the Lucent Sky Knowledge Base:
Troubleshoot source code upload errors

Resolution

  • When you access the CLI, you may see one of the following error messages:

      Operation timeout. Verify the network status or try again later. (-20005)
    
      Communication error. Verify the network status or try again later. (-20006)
    

    The CLI also returns the exit code -20005 or -20006.

    This error occurs when the CLI cnanot connect to the CLEAR Engine, or the communication between the CLI and CLEAR Engine faulted. This could either be caused by incorrect WCF endpoint configurations, or because CLEAR Engine is not running.

    To resolve this issue, follow these steps:

    • Make sure CLEAR Engine is running

      1. On the Lucent Sky AVM instance, open Windows PowerShell as administrator, and enter the following command to start the CLEAR Engine service:

         Start-Service "CLEAR Engine"
        
    • Validate WCF endpoint settings

      1. Open the CLI configuration file (SkyAnalyzer.Interface.Console.exe.config) with a text editor, and make sure WCF endpoints are configured properly.
      2. To learn more about the installation and configuration of Lucent Sky AVM Web UI, view the following article in the Lucent Sky Knowledge Base:
        Administration guide to CLEAR Engine and Web UI