Troubleshoot Lucent Sky AVM Web UI errors

2023/6/20 |

Symptoms

When you access Lucent Sky AVM Web UI, you receive an error message.

Cause

Various reasons can cause the Web UI to return an error. This article describes common causes and solutions to Web UI errors.

For Web UI errors that occurs after uploading the source code archive, view the following article in the Lucent Sky Knowledge Base:
Troubleshoot source code archive upload errors

Resolution

  • When you access the Web UI, you may see one of the following error messages:

      An error has occurred.
    
      Server Error in '/' Application.
    

    When the Web UI encountered an error and ASP.NET Custom Errors is set to on (the default setting), this error message is displayed in place of the actual error message. Temporarily turning off Custom Errors will allow the Web UI to display the actual error message.

    To turn off Custom Errors, follow these steps:

    1. Open C:\Program Files\Lucent Sky\CLEAR Web\web.config with a text editor.
    2. Locate the <system.web\\customErrors> element in web.config, and set the mode attribute to Off.

    Detailed error messages are now available. Follow troubleshooting steps to resolve the error.

    Once the error is resolved, turn on Custom Errors:

    1. Open C:\Program Files\Lucent Sky\CLEAR Web\web.config with a text editor.
    2. Locate the <system.web\\customErrors> element in web.config, and set the mode attribute to On.
  • When you access the Web UI, you are unable to create a scan and all applications are showing Loading.

    This issue occurs when JavaScript is disabled in the web browser. This issue is commonly encountered when accessing Web UI using Internet Explorer on Windows Server, as Internet Explorer is running in Enhanced Protected Mode (EPM) on Windows Server.

    To resolve this issue, follow the following steps:

    • Using Internet Explorer with EPM enabled

      1. In Internet Explorer, add the URL of Lucent Sky AVM Web UI (such as https://clear.contoso.com/) to the trusted sites zone.
    • Using Internet Explorer with EPM disabled or another browser

      1. In the browser's settings, make sure JavaScript is enabled.
      2. If a JavaScript security extension (such as NoScript) is installed, add the URL of the Web UI to its allow-list.
  • When you access Lucent Sky AVM Web UI, you may see the following error message:

      Could not load file or assembly … An attempt was made to load a program with an incorrect format.
    

    This error occurs when the Web UI is running on a 32-bit IIS Server, or a 64-bit IIS Server running on 32-bit mode.

    To resolve this issue, follow these steps:

    • The Web UI is running on a 32-bit IIS Server

      1. Install the Web UI on a 64-bit IIS Server. Running Web UI on a 32-bit IIS Server is not supported.
    • The Web UI is running on a 64-bit IIS Server running on 32-bit mode

      1. Open IIS Manager, navigate to the IIS Server that has the Web UI installed, then select Application Pools.
      2. Right click on the Application Pool CLEAR Web, then select Advanced Settings….
      3. Make sure .NET CLR Version is set to 4.0, and Enable 32-Bit Applications is set to False.
  • When you access the Web UI, you may see one of the following error messages:

      ERROR_SERVICE_NOT_ACTIVE.
    
      The communication object, System.ServiceModel.Channels.ServiceChannel, cannot be used for communication because it is in the Faulted state.
    

    This error occurs when the Web UI cannot connect to the CLEAR Engine, or the communication between the Web UI and CLEAR Engine faulted. This could either be caused by incorrect WCF endpoint configurations, or because CLEAR Engine is not running.

    To resolve this issue, follow these steps:

    • Make sure CLEAR Engine is running

      1. On the CLEAR Engine instance, open PowerShell as administrator, and enter the following command to start the CLEAR Engine service:

         Start-Service "CLEAR Engine"
        
    • Validate WCF endpoint settings

      1. Open the Web UI configuration file (web.config) with a text editor, and make sure WCF endpoints are configured properly.
      2. To learn more about the installation and configuration of Lucent Sky AVM Web UI, view the following article in the Lucent Sky Knowledge Base:
        Administration guide to CLEAR Engine and Web UI
  • When deleting a large number of applications on the Web UI, you may see one of the following error messages:

      The resource cannot be found.
    
      HTTP Error 404.15 - Not Found 
    

    This error occurs because the length of the identifiers of the application to be deleted exceeds the URL length allowed by the Web UI.

    To resolve this issue, follow these steps:

    1. Open C:\Program Files\Lucent Sky\CLEAR Web\web.config with a text editor.
    2. Locate the <system.web\\httpRuntime> element in web.config, set the maxQueryStringLength attribute to 16384, and add an attribute named maxUrlLength and set its value to 16384.
    3. Locate the <system.webServer\\security\\\\requestFiltering\\requestLimits> element in web.config, set the maxQueryString attribute to 16384, and add an attribute named maxUrl and set its value to 16384.
  • When performing long-running operations on the Web UI, such as purging scans, you may see the following error message:

      ERROR_SERVICE_REQUEST_TIMEOUT
    

    This error occurs because the connection between the Web UI and CLEAR Engine times out before the operation is completed.

    The operation will continue to run on CLEAR Engine. There is no need to perform the operation again.