Lucent Sky AVM 支援的應用程式框架和語言

2023/11/22 |

這個文章說明了不同版本的 Lucent Sky AVM 所支援的應用程式框架和語言。

支援的應用程式框架和語言

這個表格指出 Lucent Sky AVM 所支援的應用程式框架和語言1

應用程式框架 語言 版本 Lucent Sky AVM 版本2
.NET C#
VB.NET
.NET Core 1.0 - 3.1
.NET Framework 2.0 - 4.8
.NET 5 - 7
所有
Active Server Page VBScript 3.0 所有
Android C#
Dart
ECMAScript
Java
Kotlin
API Level 10 - 33 所有
C 和 C++ C
C++
C89 - C17
C++98 - C++20
所有
Go Go 1.20 所有
iOS C#
Dart
ECMAScript
Objective-C
Swift
6 - 17 所有
JDK Groovy
Java
Scala
1.5 - 21 所有
PHP PHP 4 - 8 所有
Python Python 2 - 3 所有
Ruby Ruby 2 - 3 所有
Visual Basic Visual Basic 6 所有

Lucent Sky AVM 也支援跨框架語言,例如 CFML、Dart、ECMAScript(包含 ActionScript、JavaScript、TypeScript)、HTML、SQL,以及資料交換語言,例如 JSON、XML、YAML。


1. 含有特定附加授權的 Lucent Sky AVM 實體可能支援額外語言,例如 ABAP、Apex、COBOL、SQR。

2. 僅包含仍被支援的 Lucent Sky AVM 版本(依此文章的最後修訂日期)。如果你使用的 Lucent Sky AVM 版本已經達到 EOL,請連絡 Lucent Sky 支援來了解該版本所支援的安全標準和弱點清單。