請注意:本文是以機器翻譯軟體翻譯而成,且可能由人工進行事後編修。同時,本文可能並非依照最新的英文版本翻譯而成。就翻譯內容之不正確或錯誤,或客戶因使用翻譯內容所產生的任何損害,Lucent Sky 不負擔任何責任。
症狀
在存取 CLI 時,你看到一個包含一個負的錯誤代碼的錯誤訊息。此外,CLI 亦以一個錯誤代碼結束。
原因
多種原因會導致 CLI 回傳錯誤。這個文章描述了 CLI 錯誤的常見原因及解決方式。
要深入了解關於上傳程式碼壓縮檔案後的 CLI 錯誤,請參考 Lucent Sky 知識庫:
排除程式碼上傳錯誤
解決方式
-
一個介於
-10
至-99
之間的錯誤代碼表示認證或授權錯誤。確認 API 金鑰的正確性,以及該使用者有執行該作業的權限。 -
一個介於
-100
至-999
之間的錯誤代碼為 CLEAR Engine 所回傳。依照錯誤訊息來解決該錯誤。 -
錯誤代碼
-20000
表示在執行作業時發生了一個未預期的錯誤。若該錯誤持續發生,連繫 Lucent Sky 技術支援。 -
錯誤代碼
-20004
或-20006
表示 CLI 與 CLEAR Engine 間的網路問題。確認 CLEAR Engine 服務正在執行、端點已在 CLI 中正確設定,以及 CLI 可透過 TCP/5759 與 CLEAR Engine 連線。 -
錯誤代碼
-20005
表示執行作業時發生了逾時。這通常在使用緩慢的網路連線上傳大的程式碼壓縮檔案時發生。
要深入了解 CLI 可能返回的錯誤代碼以及解決方式,請參考 Lucent Sky 知識庫:
Lucent Sky AVM CLI 參考資料