排除 Lucent Sky AVM CLI 錯誤

2021/12/21 |

症狀

在存取 Lucent Sky AVM CLI 時,你收到一個錯誤訊息。

原因

多種原因會導致 CLI 回傳錯誤。這個文章描述了 CLI 錯誤的常見原因及解決方式。

要深入了解關於上傳程式碼壓縮檔案後的 CLI 錯誤,請參考 Lucent Sky 知識庫:
排除程式碼上傳錯誤

解決方式

  • 在存取 CLI 時,你看到以下之一的錯誤訊息:

      Operation timeout. Verify the network status or try again later. (-20005)
    
      Communication error. Verify the network status or try again later. (-20006)
    

    CLI 並回傳結束代碼 -20005 或 -20006。

    這個錯誤發生於 CLI 無法連線到 CLEAR Engine 或是 CLI 和 CLEAR Engine 間的通訊發生了錯誤。發生的原因可能是因為錯誤的 WCF 端點設定,或是 CLEAR Engine 未運行。

    依照以下步驟解決這個問題:

    • 確認 CLEAR Engine 正在運行

      1. 在 Lucent Sky AVM 實體上以管理員身分開啟 Windows PowerShell,並輸入以下命令來啟動 CLEAR Engine 服務:

         Start-Service "CLEAR Engine"
        
    • 確認 WCF 端點設定

      1. 使用文字編輯器開啟 CLI 設定檔案(SkyAnalyzer.Interface.Console.exe.config)並確認 WCF 端點有被正確設定。
      2. 要深入了解關於安裝和設定 Lucent Sky AVM CLI,請參考 Lucent Sky 知識庫:
        Lucent Sky AVM CLI 管理者指南