排除授權錯誤

2023/6/13 |

症狀

在執行授權作業時,例如啟用或停用產品金鑰,安裝或解除安裝授權檔案,你收到一個錯誤訊息。

原因

這篇文章描述常見的授權錯誤的原因和解決方式。

授權作業通常使用 Web UI 或 CLEAR Engine 安裝程式 (SkyAnalyzer.Engine.Installer.exe) 進行。在安裝授權時若發生錯誤,Web UI 提供的錯誤訊息通常包含一段描述以及一個錯誤符號(例如 MALFORMED_PRODUCT_KEY),而 CLEAR Engine 安裝程式提供的錯誤訊息通常包含一段描述以及一個錯誤代碼(例如 -1)。由於描述可能變更,建議使用錯誤符號或錯誤代碼來搜尋錯誤的原因和解決方式。

解決方式

  • 在啟用產品金鑰或建立啟用要求時,你收到錯誤代碼 -11 或以下錯誤訊息:

      產品金鑰的格式不正確。(MALFORMED_PRODUCT_KEY)
    

    你收到這個錯誤,因為產品金鑰的格式不正確。

    確認所使用的產品金鑰是正確的。若問題持續發生,請連絡 Lucent Sky 技術支援。

  • 在安裝授權檔案時,你收到錯誤代碼 -12、-993、-996,或以下錯誤訊息:

      授權檔案是無效的。(INVALID_LICENSE_FILE)
    

    你收到這個錯誤,因為授權檔案是無效的。

    重新執行離線啟用。若問題持續發生,請連絡 Lucent Sky 技術支援。

  • 在啟用產品金鑰時,你收到錯誤代碼 -21、-22、-29、-991、-992,或以下錯誤訊息:

      與啟用伺服器通訊時發生錯誤。請稍後再試或使用離線啟用。(ACTIVATION_SERVER_ERROR)
    

    你收到這個錯誤,因為連絡啟用伺服器或處理啟用需求時發生錯誤。

    稍晚再嘗試啟用,或使用離線啟用。若問題持續發生,請連絡 Lucent Sky 技術支援。

    要深入了解如何離線啟用產品金鑰,請參考 Lucent Sky 知識庫:
    安裝 Lucent Sky AVM 授權

  • 在啟用產品金鑰時,你收到錯誤代碼 -31 或以下錯誤訊息:

      產品金鑰已過期或超過啟用次數。(EXPIRED_PRODUCT_KEY)
    

    你收到這個錯誤,因為產品金鑰已過期或超過啟用次數。

    大多數的產品金鑰僅能在單一的實體上被啟用。若此產品金鑰已在一個實體上被啟用,在該實體上解除啟用產品金鑰,再此實體上重新啟用。若無法解除啟用產品金鑰,請連絡 Lucent Sky 技術支援。

    要深入了解如何解除啟用產品金鑰,請參考 Lucent Sky 知識庫:
    安裝 Lucent Sky AVM 授權

  • 在啟用產品金鑰或安裝授權檔案時,你收到錯誤代碼 -41 或以下錯誤訊息:

      授權檔案中的序號和這個實體的序號不匹配。(SERIAL_NUMBER_MISMATCH)
    

    你收到這個錯誤,因為授權檔案中的序號和這個實體的序號不匹配。

    檢視授權文件以確認序號,再變更實體的序號。

    要深入了解如何變更序號,請參考 Lucent Sky 知識庫:
    變更 Lucent Sky AVM 實體的序號

  • 在啟用產品金鑰或安裝授權檔案時,你收到錯誤代碼 -42、-43,或以下錯誤訊息:

      初始化輔助授權儲存體時發生了錯誤。(SUPPLEMENT_LICENSE_STORE_ERROR)
    

    你收到這個錯誤,因為初始化輔助授權儲存體時發生了錯誤。

    輔助授權儲存體需要初始化,但此產品金鑰無法用於初始化輔助授權儲存體。請連絡 Lucent Sky 技術支援來申請重新發行此產品金鑰。

  • 在啟用產品金鑰或安裝授權檔案時,你收到錯誤代碼 -101、-109,或以下錯誤訊息:

      仍有掃描進行中。(SCAN_IN_PROGRESS)
    

    你收到這個錯誤,因為啟用產品金鑰或安裝授權檔案僅能在沒有掃描進行時執行。

    在沒有掃描進行時,重新啟用產品金鑰或安裝授權檔案。

  • 進行重大授權變更,例如變更 SKU 後,在執行某些操作時,你收到錯誤代碼 -9999980,或以下錯誤訊息:

      發生系統錯誤。(SYSTEM_ERROR)
    

    你收到這個錯誤,因為在重大授權變更後,CLEAR Engine 服務未重新啟動。

    重新啟動 CLEAR Engine 服務來使變更生效。

  • 你收到一個以上未列出的錯誤代碼或錯誤訊息。

    若你收到一個以上未列出的錯誤代碼或錯誤訊息,請連絡 Lucent Sky 技術支援,並將錯誤代碼、錯誤訊息,和紀錄檔案(若有的話)附加在服務需求中。